
VectorWorks 12.0.1 Documentation Update
This documentation contains information on a several notable user interface updates since the 
release of VectorWorks 12.0. 

New Features
The following table contains a list of new features and significant enhancements. When applicable, a 
full description of the feature is provided at the location indicated.
Note: This is a standalone documentation update. This material is not covered in the version 12 
user’s guides or help system. It will be fully integrated in a future release. 

Feature Purpose Product Location in this Update
Center snapping for 
regular polygons

Allows snapping to the center of 
closed, regular polygons

VectorWorks 
Fundamentals

“Center Snapping for 
Regular Polygons” on 
page 4-3

Viewport 
out-of-date 
indicator

The red dashed lines surrounding a 
viewport (representing an out-of-date 
viewport) no longer print

VectorWorks 
Fundamentals

Not applicable

Viewport and 
section viewport 
updating

Viewports and section viewports can 
now be updated at any time using the 
Update button on the Object Info 
palette (this puts control of updating 
in the hands of the user, rather than 
controlling it through the application)

VectorWorks 
Fundamentals 
(viewports); 
Architect, 
Landmark, 
Spotlight, and 
Machine Design 
(section 
viewports)

Not applicable

Auto-adjust 
exposure 
improvements

Changes to the auto-adjust exposure 
feature improve the rendering quality 
in Custom RenderWorks, Fast 
Radiosity, Final Quality Radiosity, 
and Custom Radiosity modes

RenderWorks “RenderWorks 
Auto-exposure 
Revisions” on page 4-4

New cabinet 
parameters

Base, utility, and wall cabinets can 
now assign a style class for both the 
cabinet body and the cabinet doors

VectorWorks 
Fundamentals, 
Architect, 
Landmark, 
Spotlight, and 
Machine Design

Not applicable

Non-orthogonal 
projection of section 
viewports

Section viewports now support 
non-orthogonal projection 

Architect, 
Landmark, 
Spotlight, 
Machine Design

“Displaying Section 
Viewports in 
Non-orthogonal 
Projection” on page 4-4
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New DTM 
parameters

New 2D and 3D triangulated display 
options are available, along with a 
related smoothing parameter

Architect, 
Landmark

“New DTM Parameters” 
on page 4-5

Objects from 
Polyline changes

Two additional objects are supported 
by the Objects from Polyline 
command, and custom path objects 
can now be added by the command

Architect, 
Landmark, 
Spotlight

“Objects from Polyline 
Changes” on page 4-7

Workspace changes The Import SketchUp command is 
now in the Architect, Landmark, and 
Spotlight workspaces

The Align Layer Views command 
has been added back to the Standard, 
Spotlight, and Machine Design 
workspaces

The Quarter Arc tool has been added 
back to the Standard workspace

Various (see 
left)

“Workspace Changes” on 
page 4-10

Import SketchUp 
command

The Import SketchUp command was 
added after version 12 was released. A 
PDF of the SketchUp import 
functionality is also included in the 
version 12.0.1 release.

Architect, 
Landmark, 
Spotlight

See SketchUp.pdf

Repetitive Unit A new parameter has been added to 
the Repetitive Unit tool
In addition, the repetitive unit offset 
path is now drawn in the object’s 
assigned line style (the path always 
has a fill style of None)

Architect, 
Landmark

“New Parameter for 
Repetitive Unit” on page 
4-12

Styled walls 
changes

Styled walls can now use class 
attributes and class textures

Architect, 
RenderWorks

“Class Attributes and 
Textures in Wall Styles” 
on page 4-12

Feature Purpose Product Location in this Update
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Center Snapping for Regular Polygons
Center Snapping for Regular Polygons
Product:  VectorWorks Fundamentals
VectorWorks now provides the ability to snap to the center of a closed, regular (equal sided) polygon. 
The polygon can be either filled or unfilled. The SmartCursor™ cue displays the word Center when 
the cursor is placed on the center point of the polygon.

Window and door 
enhancements

A number of new or revised 
parameters are available: 
• Additional commonly-used 

parameters now display in the 
Object Info palette

• Window and door detail and view 
parameters are renamed for clarity 
or localization purposes

• New user-defined fields are 
available for storing additional 
window and door information

• A new bubble size parameter 
displays in the ID Settings dialog 
box 

• Astragal is now included in the part 
list for assigning 2D line styles to 
the astragal independently from the 
object line style

• Windows and doors convert with 
greater fidelity from previous 
VectorWorks versions

Architect “Window and Door 
Enhancements” on page 
4-14

Using image props 
as 3D plant symbols

Image props of plant objects, including 
those provided by Xfrog™, can now be 
used as 3D plant symbols 

Landmark “Using Image Props as 
3D Plant Symbols” on 
page 4-17

Properly oriented 
lighting devices

Mirrored lighting devices now 
maintain a proper rotation and beams 
draw correctly

Spotlight “Properly-rotated 
Lighting Devices” on 
page 4-17

New lighting device 
parameters

New Brightness and Lit Fog 
parameters are available

Spotlight, 
RenderWorks

“New Lighting Device 
Parameters” on page 
4-17

See “SmartCursor Cues” on page 4-9 and “Regular (Equal-sided) Polygon” on page 6-39 in the 
VectorWorks Fundamentals User’s Guide for details on SmartCursor cues and creating regular 
polygons.

Feature Purpose Product Location in this Update
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RenderWorks Auto-exposure Revisions
Product:  RenderWorks
The Custom RenderWorks and Custom Radiosity rendering modes have an Auto-Adjust Exposure 
option. When this option is enabled, RenderWorks automatically adjusts the exposure when 
rendering scenes with too much illumination. Fast Radiosity and Final Quality Radiosity modes 
always use the auto-adjust exposure feature.
The following improvements have been made to the auto-adjust exposure feature.
• Renderings are now brighter; they were sometimes too dark in the previous version.
• Luminance levels have been adjusted to maximize contrast.
• Locating translucent surfaces close to light sources no longer causes the rendering to become 

dark. Using translucent shaders rather than constant shaders with light sources is 
recommended, since constant shaders are limited in the brightness they can show.

• Lit fog no longer causes the rendering to become dark.
• A rendering’s brightness is no longer affected by the amount of background shown in it.

Displaying Section Viewports in Non-orthogonal 
Projection
Product:  Architect, Landmark, Spotlight, and Machine Design
A section viewport can now be displayed in a non-orthogonal projection (perspective, cabinet, and 
cavalier) for straight section lines. 

1. Select a section viewport. 

2. Select the desired projection in the Object Info palette. If a perspective projection is selected, a 
perspective type and custom perspective distance can also be specified.

See “Creating a Section Viewport” on page 22-1 in the VectorWorks Design Series User’s Guide 
for details on creating section a viewport. 
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New DTM Parameters
New DTM Parameters
Product:  Architect and Landmark
A new parameter, Smoothing Interval, and new 2D and 3D triangulated contour display styles 
have been added to the site model display options, which are available when creating a new site 
model with the Create Site Model command, or when editing a selected site model by clicking Site 
Model Settings from the Object Info palette. The order of parameters in the dialog box has changed 
slightly to accommodate the new parameter.
The new 2D and 3D display options are also available for a selected site model from the Object Info 
palette.

Parameter Description
Projection Select the projection type for the section viewport (see “Projection” on page 13-3 in 

the VectorWorks Fundamentals User’s Guide)
Perspective 
Type

For Perspective projection, select the type of perspective, or choose Custom and 
specify the perspective distance

Perspective 
Dist

For custom perspectives, enter the perspective distance
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For more information on the Create Site Model or Site Model Settings dialog box, see “Creating 
the Site Model” on page 9-8 in the VectorWorks Design Series User’s Guide.

Parameter Description
Smoothing Interval When selecting a triangulation method for 2D and/or 3D site model display, 

sets the distance for adding new points to the contours. Enter zero to use the 
original contour points for triangulation.

2D Display Style Two new 2D display styles are available
2D Triangulated 
Contours

Draws 2D contour lines by triangulation, according to the specified 
Smoothing Interval

2D Triangulated 
Contours (colored 
slopes)

Draws 2D contour lines by triangulation, according to the specified 
Smoothing Interval, and colors the slopes within specified angle ranges for 
conducting a slope analysis

3D Display Style Three new 3D display styles are available
3D Triangles (colored 
slopes)

Generates 3D triangles with the Triangulated Irregular Network (TIN) 
method, and colors the slopes within specified angle ranges for conducting a 
slope analysis
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Objects from Polyline Changes
Objects from Polyline Changes
Two new objects are supported by the Objects from Polyline command, and the ability to use the 
command with custom objects is now supported.

New Objects Supported
Product:  Architect and Landmark
The Objects from Polyline command, located on the Modify > Convert menu, now supports both 
Repetitive Unit and Linear Material objects.

Custom Path Objects
Product:  Architect, Landmark, and Spotlight
The Objects from Polyline command now supports custom path objects (custom path plug-in 
objects with a .vso extension).

3D Triangulated 
Contours

Draws 3D contour lines by triangulation, according to the specified 
Smoothing Interval

3D Triangulated 
Contours (colored 
slopes)

Draws 3D contour lines by triangulation, according to the specified 
Smoothing Interval, and colors the slopes within specified angle ranges for 
conducting a slope analysis

For more information on the Objects from Polyline command, see “Creating Objects from 
Polylines” on page 22-41 in the VectorWorks Design Series User’s Guide.

For more information on these objects, see “Detail Drawings” on page 8-16 in the VectorWorks 
Design Series User’s Guide.

For information on creating custom path objects, see “VectorScript Objects” on page 13-1 in the 
VectorScript Language Guide.

Parameter Description
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To add a custom path object to the Objects from Polyline command:
1. Place the custom path object file in the VectorWorks\Plug-Ins folder.
2. Select Tools > Scripts > VectorScript Plug-in Editor.

The VectorScript Plug-in Editor dialog box opens.

3. In the list of VectorScript plug-ins, select Objects from Polyline.

4. Click Strings.
The String Categories dialog box opens.

5. Select Resource ID 6000, User Defined Path Objects, and click Edit.
The Edit Strings dialog box opens.

Press the letter O key to quickly access the Objects from Polyline plug-in.
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Objects from Polyline Changes
6. Select ID 6001, and click Edit.
7. The Edit String dialog box opens. 

Enter the number of custom path objects that will be added, and click OK. (If adding one path 
object, enter 1.)

8. In the Edit Strings dialog box, click Add.
The Edit String dialog box opens.

9. Enter the name of the path object that should be used in the command list, and then the actual 
name of the plug-in object file (without the .vso extension), separated by a colon.

10. Click OK to return to the Edit Strings dialog box.
The custom path object ID and string are listed.
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11. Repeat steps 8 – 10 for each custom path plug-in object to add. 
12. Click OK twice, and then Done, to exit the VectorScript Plug-In Editor.
13. The custom path object is included in the list of path objects created by the Objects from 

Polyline command.

Workspace Changes

Importing SketchUp Files
Product:  Architect, Landmark, and Spotlight
The Import SketchUp command is now located in the File > Import menu in the Architect, 
Landmark, and Spotlight workspaces. See the SketchUp.pdf included with this release for more 
information.

Aligning Layer Views
Product:  VectorWorks Fundamentals, Spotlight, and Machine Design
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Workspace Changes
The Align Layer Views command has been added back to the Standard, Spotlight, and Machine 
Design workspaces.
The Align Layer Views command provides a one-step way to change all the design layers in the 
drawing file so that they have identical Standard View and Projection modes. VectorWorks matches 
all design layers, regardless of visibility, to the Standard View and Projection modes of the active 
layer. 
To align design layer views:

1. Select View, and then set the Standard Views and Projection modes for the active layer.
2. Select View > Align Layer Views.

VectorWorks changes the Standard Views and Projection modes for all of the design layers in the 
drawing file.

Creating Quarter Arcs
Product:  VectorWorks Fundamentals
The Quarter Arc tool has been added back to the Standard workspace. 
The Quarter Arc tool creates circular 90° arcs or 90° elliptical arc polyline objects. 
Note: Quarter arcs are listed as polylines in the Object Info palette. 
To create quarter arcs:

1. Click the Quarter Arc tool from the Basic palette. 
2. Click at the start point for the arc.
3. Click at the end point for the arc.

Note: The ratio of the arc’s height to its width displays in the Data Display bar (a quarter arc for a 
circle has a ratio of 1.000). 
Use the Data Display bar to verify or modify an arc’s angle, length, and location in a drawing.

Active layer

1st click

2nd click
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New Parameter for Repetitive Unit
Product:  Architect and Landmark
The Repetitive Unit tool draws world-scale symbols along a path, creating repetitive elements such 
as masonry units, shingles, and siding. 

A new parameter, Use Vertical Pitch, has been added.

Class Attributes and Textures in Wall Styles
Product:  Architect
Wall styles can now use class attributes and class textures. This allows viewport class overrides to 
apply to styled walls, and eliminates the concept of wall style default textures.

Using Wall Style Class Attributes
Product:  Architect
A new option, Use Class Attributes, sets the wall attributes of styled walls by class rather than in 
the Wall Attributes dialog box. When a styled wall is created with that wall style, its wall fill and pen 
attributes are set by the wall’s class. If the wall class is changed later, the wall changes to use the 
attributes of the new class. Wall attributes cannot be overridden on a per-instance basis; if a wall 
style uses class attributes, all walls of that style must use class attributes. However, walls of the same 
wall style can be placed in different classes.
To use class attributes for a wall style:

1. Either click the Wall Preferences mode button, or select a wall style in the Resource Browser 
and select Edit from the Resources menu.

2. The Wall Preferences or Edit Wall Style dialog box opens.
3. On the Wall Definition tab, select Wall from the Wall Structure List. Click Edit.

The Wall Attributes dialog box opens.

See “Creating Repetitive Unit Details” on page 8-19 in the VectorWorks Design Series User’s 
Guide.

Parameter Description
Use Vertical 
Pitch

Rotates the symbol 90 degrees counter-clockwise and sets the pitch vertically; this 
is useful for symbols that are to be stacked vertically rather than arrayed vertically, 
as they can be drawn in a more natural way

For more information on wall styles, see “Creating Walls in Architect” on page 5-1 in the 
VectorWorks Design Series User’s Guide.
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Class Attributes and Textures in Wall Styles
4. Select Use Class Attributes to set the styled wall attributes by class. The wall’s fill and pen 
attributes can no longer be set from this dialog box, since they are applied by class.

5. Click OK.

Using Wall Style Class Textures
Product:  Architect and RenderWorks
Wall styles can now use class textures by selecting Class Texture for the left, center, or right portion 
of the wall (RenderWorks required). Any walls with that wall style use class textures for that part of 
the wall (unless overridden). On the Render tab of the Object Info palette for a selected wall, default 
wall style textures are no longer present; like un-styled walls, class textures are available.
To select class textures for styled walls:

1. Either click the Wall Preferences mode button, or select a wall style in the Resource Browser 
and select Edit from the Resources menu.
The Wall Preferences or Edit Wall Style dialog box opens. Click the Textures tab.
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2. For each section of the wall where a texture is defined, select Class Texture to use the texture 
defined by the wall’s class.
Class Texture can also be chosen for a selected wall in the Render tab of the Object Info palette.

Window and Door Enhancements
Product:  Architect
A number of new parameters are available for windows and doors, a few parameters were renamed 
for clarity or localization purposes, and the Object Info palette now contains additional 
commonly-used parameters for easier window and door editing.

Additional Object Info Palette Parameters
Additional commonly-used parameters now display on the Object Info palette for easier editing. For a 
black symbol made from a window or door object, fields pertaining to geometry do not display. New 
parameters include the following:

See “Inserting Windows” on page 6-1 and “Inserting Doors” on page 6-11 in the VectorWorks 
Design Series User’s Guide for a description of the parameters now displaying on the Object Info 
palette.
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Window and Door Enhancements
Renamed Wall Detail and View Parameters
The splay wall parameters on the Wall Detail tab of the Window and Door Preferences dialog boxes 
have been renamed for localization purposes.

The line weights parameters on the View tab of the Window and Door Preferences dialog boxes have 
been renamed to more accurately represent their purpose.

Parameters
• Use Wall Depth • Draw Wall Lines (window 

object only)
• Plan Detail

• Show Hinge Direction 
(window object only)

• Show 3D Open and Angle 
(door object only)

• Include Interior / Exterior 
Trim, Width, and Thickness

• Trim Under Stool (window 
object only)

• Trim Under Sill (window 
object only)

• Interior/Exterior Comps

• Use Part Line Styles • On Schedule • ID Prefix
• ID Label • ID Suffix • ID Label Size
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User-defined Record Parameters
New fields are available for storing additional window and door information. Click the Data tab of the 
Window and Door Preferences dialog boxes to specify the record information to include on the window 
or door schedule. User Field 1 to User Field 9 (or User Field 10 for doors) can be used to include 
additional user-defined window or door information.

New Bubble Size Parameter
The Bubble Size parameter now displays in the ID Settings dialog box. 

1. From the Data tab of the Window or Door Preferences dialog boxes, click ID Settings.
The ID Settings dialog box opens for specifying ID label parameters.

See “Inserting Windows” on page 6-1 and “Inserting Doors” on page 6-11 in the VectorWorks 
Design Series User’s Guide.
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Using Image Props as 3D Plant Symbols
2. Click OK to close the ID Settings dialog box and return to the Window or Door Preferences dialog 
box.

New Astragal Parameter for Doors
The View tab of the Door Preferences dialog box now includes astragal in the part list for assigning 
2D line styles to the astragal independently from the object line style.

Using Image Props as 3D Plant Symbols
Product:  Landmark
Image props, including those provided by Xfrog™, can now be assigned as 3D plant symbols. Several 
default resource image props are provided in 
[VectorWorks]\Libraries\Defaults\Plants - 3D Symbols\3DPlantSymbols.mcd. Custom default 
resources can also be created from image props. Once the image props are in the correct location, they 
may be selected from the 3D Symbol preview in the New Plant Definition dialog box.

Lighting Device Changes

Properly-rotated Lighting Devices
Product:  Spotlight
Mirrored lighting devices maintain their proper rotation and beams are drawn properly for flipped or 
mirrored lighting devices. Files converted from version 11 are automatically updated. Lighting 
devices in version 12 files must be updated. To do so, open a version 12 file containing lighting 
devices. With nothing selected, select Modify > Refresh Instruments. All lighting devices in the 
current file are updated.

New Lighting Device Parameters
Product:  Spotlight and RenderWorks
Two new parameters are available on the Light Information tab of the Lighting Device dialog box and 
also on the Object Info palette for a selected lighting device. To access the Lighting Device dialog box, 

Parameter Description
Bubble Size Specify the size of the ID label bubble (this value represents the bubble size times 

the layer scale; the bubble shape is maintained relative to the text inside it for ID 
bubble uniformity throughout the drawing file)

See “Modifying the Window or Door ID Label” on page 6-24 in the VectorWorks Design Series 
User’s Guide for a description of the other ID label parameters.

See “VectorWorks Fundamentals Default Resources” on page 5-1 in the VectorWorks 
Fundamentals User’s Guide; also see “Defining Plants” on page 11-2 and “Plant Symbol 
Specifications” on page A-15 in the VectorWorks Design Series User’s Guide.
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double-click a lighting device in the drawing, or select a lighting device and click Edit in the Object 
Info palette. The Lighting Device dialog box opens.

Parameter Description
Brightness (%) Controls the intensity of the light inside the lighting device; drag the slider to the 

right to increase the light intensity. In the Object Info palette, enter a numerical 
brightness percentage value. 

Lit Fog 
(RenderWorks 
required)

Enables the lit fog weather effect; see “Creating Weather Effects” on page 21-24 in 
the VectorWorks Fundamentals User’s Guide

See “Lighting Instrument Properties” on page 13-3 and “Changing Instrument Properties” on 
page 13-8 in the VectorWorks Design Series User’s Guide for a description of the other light 
information parameters.
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