
VectorWorks Reference

Welcome to the VectorWorks 3D Power PackTM. The 3D Power Pack is an 
additional module that works with VectorWorks 9.5.1 to provide significantly 
expanded NURBS (Non Uniform Rational B-Splines) functionality.
NURBS is a mathematical formulation that represents the geometry of curves 
and surfaces in 3D space. In the previous version of VectorWorks, NURBS 
curves, circles, and arcs were available. The 3D Power Pack adds the new 
functionality of creating NURBS curves and surfaces to significantly increase 
the 3D operations possible in VectorWorks.
The 3D Power Pack provides the following features and benefits:
• Advanced solid modeling operations
• Advanced surface modeling operations
• Solid-surface interactions
• Participation of surfaces in Boolean operations
• Easy manipulation of surface geometry
• Simple 3D user interface

To navigate to the topic you are interested in, either select it from the table 
of contents on the left, or use the Acrobat Find and Search features. A 
comprehensive index is also included, which can be accessed by clicking 
Index from the table of contents.
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License Agreement
NNA grants the buyer a non-exclusive license to use the 
software in the package according to the terms set forth below. 
The software is protected by copyright laws and international 
copyright treaties, as well as by other intellectual property laws 
and treaties.
This program has been purchased for a single, specific operating 
system per serial number. It is licensed for installation on one 
machine for each serial number.

The Buyer May:
Install and operate this software on one computer at a time; make 
one back-up copy of the software, which is automatically subject 
to this agreement, and modify unprotected VectorScript routines 
provided with this software.
The Buyer May Not:
1: Make this software available to any person or entity other than 
employees who must use this software as specified above.
2: Modify or merge the software with another program, except 
for personal use as described above.
3: Disassemble, decompile, reverse engineer, or attempt in any 
fashion to discover the source code of the software.
4: Sub-license, sell, lend, rent, or lease any portion of the 
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transfer all (but no portion thereof) of the software to another 
person or entity, who in turn is subject to this agreement.
5: Operate the software on more than one computer at a time. 
(Site licenses are available from NNA for multi-station use. All 
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NOTE: This software involves valuable proprietary rights of 
NNA and others. There is no transfer to the buyer of any title to, 
or ownership of, this software; nor is there transfer of any patent, 
copyright, trade secret, trade name, trademark, or other 
proprietary rights related to the software. The buyer may not 
violate these rights and must take appropriate steps to protect 
NNA’s rights. NNA may at any time replace, modify, alter, 
improve, enhance, or change the software. The license and the 
buyer's right to use the software terminate automatically if the 
buyer violates any part of this agreement. In the event of 
termination of buyer’s right to use the software, all copies of the 
software must be destroyed or immediately returned to NNA.

Upgrades:
All upgrades or sequential versions of the program obtained 
under upgrade agreements or offered at a later date in 
consideration of this purchase will be considered one program 
under this license agreement. Under no circumstances will the 
providing of upgrades be considered as permission for this 
program to reside on more than one computer at any time, nor 
may the buyer sub-license, sell, lend, rent, or lease any portion of 
former versions of the software. Again, the license and the 
buyer’s right to use the software terminate automatically if the 
buyer violates any part of this agreement. In the event of 

termination of buyer’s right to use the software, all copies of the 
software must be destroyed or immediately returned to NNA.

General:
NNA is not responsible for maintaining the software or for 
helping the buyer in the use of said software except through the 
Registered User Support Service. This agreement constitutes the 
entire agreement and supersedes any prior agreement between 
NNA and the buyer.
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1VectorWorks 3D Power Pack
In this Chapter:

• Overview

• NURBS Curves

• NURBS Surfaces

• NURBS 
Surface-Curve 
Interaction

• Solids Operations

• Exporting in 3D 
Power Pack
Overview

3D Power Pack Workspace

To access the 3D Power Pack menus and tools, select File 
> Workspaces > Standard 3D Power Pack. The 3D 
Power Pack workspace opens.

3D Power Pack Tools and Commands

Several new tools and commands have been added to the 
3D Power Pack workspace. Other tools and commands 
have been modified to take advantage of the new NURBS 
functionality.

Name Purpose Location

Extract Curve tool Extracts NURBS curves from the edges of 
a solid

“Extracting Curves” on 
page 1-7

Create Contours tool Creates contours at specified intervals “Creating Contours” on 
page 1-8

Connect/Combine tool Three new options for dual object 
connect/combine have been added to this 
modified tool

“Curve Matching” on 
page 1-9

Convert to NURBS 
command

This command has been modified to 
include the conversion of solids faces to 
NURBS surfaces

“Converting to NURBS” 
on page 1-11

Extract Surface tool Extracts NURBS surfaces from the faces 
of a solid

“Extracting a NURBS 
Surface from a Solid” on 
page 1-12

Loft Surface tool Creates one or more NURBS surfaces 
from two or more cross-sections

“Creating a Loft Surface” 
on page 1-13

Create Surface from 
Curves command

Creates a NURBS surface from a network 
of intersecting NURBS curves

“Creating Surfaces from 
Curves” on page 1-16
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Create Fillet Surface 
command

Creates a surface tangential to two 
selected surfaces

“Creating a Fillet 
Surface” on page 1-19

Create Planar Caps 
command

Creates planar NURBS surfaces to cap the 
holes in a solid

“Creating Planar Caps” on 
page 1-20

3D Reshape tool This tool has been modified to manipulate 
NURBS surface control points

“Reshaping Surfaces” on 
page 1-21

Compose command Formerly the Compose Curve command, 
the modified Compose command can now 
handle NURBS surfaces

“Composing Surfaces” on 
page 1-25

Decompose command Formerly the Decompose Curve 
command, the modified Decompose 
command can now handle NURBS 
surfaces

“Decomposing Surfaces” 
on page 1-25

Split tool This tool has been modified to split 
NURBS surfaces and solids by point or 
line

“Splitting NURBS 
Surfaces” on page 1-26

Project and Trim tool Trims a surface by projecting a curve on it “Trimming NURBS 
Surfaces with a 
Projection” on page 1-29

Blend Edge tool Creates a fillet or chamfer to remove the 
sharp corners of a solid

“Blending Edges” on page 
1-30

Shell Solid tool Creates a thin shell from a solid object “Creating a Shell from a 
Solid Object” on page 
1-33

Tapered Extrude 
command

This command has been modified to 
create tapered extrudes from NURBS 
curves and 3D polygons

“Creating a Tapered 
Extrude” on page 1-35

Stitch and Trim 
Surfaces command

Creates a group of trimmed NURBS 
surfaces from several intersecting 
NURBS surfaces

“Stitching and Trimming 
Surfaces” on page 1-36

Section Solids 
command

Solids can be sectioned by a surface, 
discarding the geometry on one side of the 
sectioning surface

“Sectioning Solids” on 
page 1-37

Export IGES command Exports NURBS curves, surfaces, and 
solids from VectorWorks

“Exporting in IGES 
Format (3D only)” on 
page 1-38

Flyover Boomerang 
mode

To obtain the flyover tool in Pause/
Boomerang mode, press spacebar + B. 
Release the spacebar + B to return to the 
3D Power Pack tool.

Applies to all version 
9.5.1 tools

Name Purpose Location
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3D Power Pack Compatibility

All geometry created with the 3D Power Pack is supported in VectorWorks 
9.5.1, including versions of VectorWorks 9.5.1 without the Power Pack 
module installed.
All Power Pack operations, with the exception of blends, shells, and section 
solids, are supported in previous releases of VectorWorks 9. Objects with 
blended edges, shells, and section solids are deleted in versions of 
VectorWorks prior to 9.5.1.
3D Power Pack geometry is not supported in versions of VectorWorks prior to 
version 9.

3D Power Pack Cursors

Several new cursors have been introduced in the 3D Power Pack. These 
appear during certain operations to help determine the current mouse 
function; they do not display when an active selection is about to occur.

Selecting the Edges and Faces of a Solid

Several 3D Power Pack tools require the selection of edges or faces of a solid. 
The Extract Curve tool requires edge selection, while the Extract Surface 
and Shell Solid tools require face selection. The Blend Edge tool can 
require both face and edge selection, depending upon the option selected in 
Blend Edge Preferences dialog box.

Cursor/Operation Tool Where Used

Edge Selection Extract Curve tool and Blend Edge tool

Face Selection Extract Surface tool and Shell Solid tool, as well as the 
Blend Edge tool with Select Faces option turned on

Curve Selection Loft Surface tool and Project and Trim tool

Surface Selection Project and Trim tool
VectorWorks 3D Power Pack User’s Guide 1-3
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Selecting Edges

An edge is selected by clicking on that edge. When you are near an edge, the 
cursor changes to an arrowhead. This is an indication that you are on an object 
that you can select by clicking on it. If there is more than one edge near the 
cursor, the nearest edge is selected.

The cursor changes to an arrowhead when you are on or near an edge, or an 
iso-parametric curve drawn in lighter shade of the pen color of the solid. In 
the above solid, the iso-parametric curves are drawn in light gray. Although 
the cursor changes near these curves, these curves cannot actually be selected. 
Only edges displayed in a dark color can be selected.

To select more than one edge Press the Shift key and select the edges

To deselect a selected edge Click on the edge again with the Shift key pressed

To deselect the edges that 
have been selected

Click on an empty area

To deselect the last selection Press the Backspace (Win) or Delete (Mac) key, or 
double-click on the edge

Arrow cursor
(away from edge)

Arrowhead cursor
(on or near edge)

Highlighted
(selected) edge

Iso-parametric
curve
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Selecting Faces 

Face selection in VectorWorks is actually an edge-based selection. When you 
are on an edge or near an edge or near an iso-parametric curve, you can select 
the face on either side of the edge depending on the cursor position.

If the cursor is positioned over more than one face, or near an iso-parametric 
curve on a face, the Select Face dialog box opens to specify which face to 
select.

Selecting multiple 
edges

Cursor pointing to the 
left side of the edge

Face on the left side of 
the edge is selected

Cursor pointing to the 
right side of the edge

Face on the right side 
of the edge is selected
VectorWorks 3D Power Pack User’s Guide 1-5



VectorWorks 3D Power Pack
Click the arrow keys until the desired face is selected. Click OK to select the 
face.
Multiple faces can be selected while pressing the Shift key, much like the 
edge selection described earlier. Deselecting faces is also similar to 
deselecting edges.

Editing a Fillet/Chamfer or Shell Object

A fillet, chamfer, or shell object follows certain editing conventions.
The set of edges or faces used to create the fillet/chamfer or shell cannot be 
changed once the operation is performed; edges or faces cannot be deleted 
from or added to the existing set. To add or delete edges or faces, first 
ungroup the object, and then perform the operation again.

The properties that can be changed from the Object Info palette include the 
thickness of a shell, the radius of a fillet or setback distance of a chamfer. 
However, only the parameters of the topmost object can be changed.
For example, if a shell is created, and then some of the shell edges are filleted, 
only the fillet parameters can be changed directly from the Object Info palette. 
To change the shell thickness, the fillet object must first be ungrouped. To 
change the original extrusion, both the fillet and the shell must be ungrouped. 
Once changes have been made, reapply the shell and fillet.

Iso-parametric 
curve

Fillet operation performed Ungroup to change 
existing set of edges

Fillet operation performed 
with new set of edges
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NURBS Curves 1
Note: The Organize > Edit Group command cannot be used for these 
objects. The history of these objects is not retained; therefore, they 
cannot be regenerated automatically.

Surface Geometry Requirements

Some surface geometry can contain degenerate patches, singularities, or 
self-intersections. These types of surfaces could potentially be produced with 
the 3D Reshape tool, Loft Surface tool, or Create Surface from 
Curves command, and can produce undesirable results in the finished model. 
Surface operations, such as stitch/trim and split, and other operations, like 
creating contours and solid operations, may not be able to manipulate these 
types of surfaces.

NURBS Curves

Extracting Curves

The Extract Curve tool extracts a NURBS curve from the edge of a solid 
object, leaving the original unmodified. The extracted curves can then be used 
for other surface operations.
To extract a NURBS curve from the edge of a solid object:
1. In the desired view, click the Extract Curve tool from the 3D Tools 

palette.

2. Holding the Shift key, select the edge(s) of the object to be extracted.

3. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to extract the selected NURBS curves.

Extract Curve Tool
VectorWorks 3D Power Pack User’s Guide 1-7



VectorWorks 3D Power Pack
Note: To edit the curve(s), select Organize > Ungroup.

Creating Contours

Contours are intersections of a solid or surface with a plane passing through 
the line specified with the Create Contours tool. This tool creates contours 
at specified intervals, which can then be used to create a loft surface in order 
to recreate a solid shape.
To create contours:
1. Click the Create Contours tool from the 3D Tools palette. 

2. Click the Preferences button on the Mode bar to specify the contour 
interval.

3. Click and drag to indicate the position of the intersecting plane.

The contours, a group of NURBS curves, are drawn in red.

Extracted curves have been 
ungrouped and moved for clarity

Create Contours 
Tool
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Curve Matching

The Connect/Combine tool joins objects by their endpoints or at their 
intersections using one of three modes: Single Object Connect, Dual Object 
Connect, or Dual Object Combine.

When connecting or combining a pair of NURBS, polylines, or open 
polygons by their endpoints, VectorWorks may require additional information 
to complete the process. In this situation, the Connect/Combine Options 
dialog box opens.

Connect/Combine Tool

Single Object Connect Dual Object Combine

Dual Object Connect
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Option Description

Mid-Point Connects/combines the two objects by joining the two 
endpoints midway between them

Blend Connects/combines the two objects by creating another 
object between them

Position Matching 
(NURBS curves only)

Connects/combines two NURBS curves by moving the 
first object’s selected end point to the selected end 
point of the boundary object. Not available if the end 
points are coincident.
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The Connect/Combine tool modes are described in the VectorWorks 
User’s Guide.

NURBS Surfaces

Converting to NURBS

In addition to the previous behavior of converting 2D curves to NURBS 
curves, the Convert to NURBS command now converts the faces of solids 
to NURBS surfaces. This is a quick way of creating NURBS surfaces from an 
extrusion, sweep, or other solids.
To convert to NURBS surfaces:
1. Select the solid to convert to NURBS surfaces.

Tangency Matching 
(NURBS curves only)

Connects/combines two NURBS curves by making the 
first object’s selected end point tangent with the 
selected end point of the boundary object

Curvature Matching 
(NURBS curves only)

Connects/combines two NURBS curves by making the 
first object’s selected end point match the curvature of 
the selected end point of the boundary object

Option Description
VectorWorks 3D Power Pack User’s Guide 1-11
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2. Select Model > Convert to NURBS.

The selection is converted to NURBS surface(s).

Note: If the solid consisted of several faces, the result of the conversion will 
be a group of NURBS surfaces. Select Organize > Ungroup to 
access the individual NURBS surfaces that make up the solid.

Extracting a NURBS Surface from a Solid

The Extract Surface tool extracts NURBS surfaces from the faces of a 
solid, leaving the original object unmodified. The extracted NURBS surface 
can be used for sectioning solids or for stitch/trim surfaces.
To extract the surface from a solid:
1. Click the Extract Surface tool from the 3D Tools palette.

Extract Surface 
Tool
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2. Select one or more faces to be extracted.

Note: See“Selecting the Edges and Faces of a Solid” on page 1-3 for 
information on selecting surfaces.

3. Press the Enter (Win) or Return (Mac) key or the check mark button on 
the Mode bar to extract the surface.

The extracted NURBS surface is displayed in red.

Creating a Loft Surface

The Loft Surface tool creates a complex NURBS surface(s) from two or 
more cross sections. Similar to the Multiple Extrude command, the Loft 
Surface tool creates a 3D object from a series of other objects. Unlike 
Multiple Extrude, the cross sections do not need to be equally spaced, and 
the resulting profile can be manipulated to avoid self-intersection and to 
control twist.
Note: This tool can potentially create surfaces which cannot be further 

manipulated in the 3D Power Pack. See “Surface Geometry 
Requirements” on page 1-7.

Surface moved for clarity

Loft Surface Tool
VectorWorks 3D Power Pack User’s Guide 1-13



VectorWorks 3D Power Pack
To create a NURBS surface from two or more cross sections:
1. Click the Loft Surface tool from the 3D Tools palette.

2. Click on each cross section. The cursor changes into an arrowhead when 
over a valid cross section. The point nearest to the click is selected.

The proposed curve alignment displays in red as each section is selected.

Note: Cross sections are created using NURBS curves which do not need to 
be the same shape or planar. Curves must be either closed or open 
objects, not a mixture of the two. 3D loci can be used in a loft but 
must appear at the ends of the loft.

3. Once all curves are selected, press Enter (Win) or Return (Mac) or the 
check mark button on the Mode bar.

The Loft Creation dialog box opens.

Cross section Basic loft Twisted loft
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4. Specify the desired loft creation settings.

Parameter Description

Select Curve Selects the previous or next cross-section curve. 
Reverse changes the direction of the curve to twist or 
untwist the loft surface.

Select Alignment by Point Selects the previous or next point on the selected cross 
section curve. If the cross section does not have any 
corners, this option is disabled. 

Select Alignment by 
Percentage

Selects points along a geometrically-continuous cross 
section (circle, oval, etc.) by a specified percentage, or 
by adjusting the slider

Ruled Creates a linearly-interpolated object

Reverses the
curve direction

Moves to and highlights 
the previous or next curve

Moves to and highlights  the 
previous or next valid point

Selects a point along the curve 
by a percentage of curve length

Previews the proposed 
final geometry

Creates linear
surfaces

Creates closed
surfaces

Creates a solid
object
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5. Click OK to close the dialog box and create the loft surface(s).

Creating Surfaces from Curves

The Create Surface from Curves command creates a NURBS surface 
from a network of single closed curves (including closed 2D objects) or two 
or more open NURBS curves. These NURBS curves can be planar or 
non-planar, but NURBS in the U direction must intersect NURBS in the V 
direction at only one point.

Closed Creates a loft surface that closes in on itself. As the 
start point cannot be selected as the end point of a loft, 
the Closed option automatically completes the 
connection.

Create Solid Creates a loft surface whose ends are capped and all 
surfaces are stitched together to create a solid object

Preview Displays the proposed loft surfaces based on the 
current settings

Parameter Description

Cross section Loft surface without 
Closed option

Cross section with Closed 
option
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Note: This command can potentially create surfaces which cannot be 
further manipulated in the 3D Power Pack. See “Surface Geometry 
Requirements” on page 1-7.

To create a NURBS surface from curves:
1. Draw two or more open NURBS curves to create an enclosed region.

2. Select the NURBS objects being used to create the NURBS surface.

3. Select Model > Create Surface from Curves.

A NURBS surface is created with a red pen color.

Note: Multiple open NURBS that form both boundary and interior curves 
can be used to create a NURBS surface, but must have an equal 
number of intersections.
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A NURBS surface is not created if:

There is more than one 
intersection, creating multiple 
enclosed regions

There is an intersection between 
curves in the same parametric 
direction

Only one enclosed region allowed

Intersection between curves in the 
same parametric direction
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Creating a Fillet Surface

The Create Fillet Surface command creates a surface tangential to two 
selected surfaces, leaving the original surfaces unmodified. 
This command is useful for sheet metal design (e.g.for car bodies) to provide 
a smooth transition between two adjacent surfaces – perhaps for aesthetic 
quality or because of a manufacturing requirement.
To create a surface tangential to two selected surfaces:
1. Select two NURBS surfaces to create the filleted surface.

2. Select Model > Create Fillet Surface.

The Set Fillet Radius dialog box opens.

3. Enter the desired Fillet Radius, and then click OK.

There are an unequal number of 
intersections

Unequal number of intersections
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A NURBS surface is created tangentially between the two objects.

The resulting fillet can then be used to create a seamless join between 
NURBS surfaces.
To create a seamless join between NURBS surfaces:
1.  Select all NURBS surfaces, and then select Model > Add Solids to 

add the fillet surface to the NURBS surface.

2. With the surfaces still selected, select Model > Convert to NURBS to 
convert all the surfaces of the solid to NURBS surfaces.

3. Select Organize > Ungroup to display all individual surfaces.

4. Click on the drawing area to deselect the objects. Delete the surfaces that 
are not to be used in the final object.

Creating Planar Caps

The Create Planar Caps command closes off the ends of open-ended solids 
by creating planar NURBS surfaces. These surfaces can then be added to the 
rest of the surfaces with the Add Solids command.

Fillet surface
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To create planar caps:
1. Select the open-ended solid.

2. Select Model > Create Planar Caps.

Planar NURBS surfaces are created to close off the ends of the solid.

3. Add the solid and the planar cap surfaces by selecting them all and 
choosing Model > Add Solids.

Reshaping Surfaces

The 3D Reshape tool, located on the 3D Tools palette, can now be used to 
manipulate NURBS surface control points.
NURBS surfaces can be reshaped with this tool. For example, a dome or bell 
curve effect can be created by manipulating the vertices.
Note: This tool can potentially create surfaces which cannot be further 

manipulated in the 3D Power Pack. See “Surface Geometry 
Requirements” on page 1-7.

To reshape a NURBS surface:
1. Select the NURBS surface to reshape.

Planar caps moved for clarity

3D Reshape Tool
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2. Click the 3D Reshape tool from the 3D Tools palette.

Select the mode from the Mode bar.

If one vertex or row of vertices is to be selected, position the cursor over 
one of the NURBS surface vertices. When the cursor is over a vertex, the 
standard arrow cursor changes to an unfilled, four-way arrow. 

Several vertices can be selected at one time by clicking with the Shift key 
pressed or by drawing a marquee around the desired vertices.

Move NURBS Surface 
Vertex

Changes the position of the selected vertex or vertices only

Move NURBS Surface U 
Vertices

Changes the position of all vertices in a row in the U 
direction

Move NURBS Surface V 
Vertices

Changes the position of all vertices in a row in the V 
direction

Working plane constrain Moves the selected vertex or vertices on a working plane

X axis constrain Moves the selected vertex or vertices along the x axis

Y axis constrain Moves the selected vertex or vertices along the y axis

Z axis constrain Moves the selected vertex or vertices along the z axis

Z axis constrain
Move NURBS

Surface Vertex

Move NURBS Surface 
U Vertices

Move NURBS Surface 
V Vertices

Working plane constrain

X axis constrain

Y axis constrain
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 If several vertices are selected, position the cursor over one of them.

3. Click-drag the mouse to move the vertex or vertices.

4. Release the mouse at the desired location.

NURBS Surface Properties

The properties of a NURBS surface are displayed in the Object Info palette, 
where they can also be edited.

One vertex selected and moved A group of vertices selected and moved
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Parameter Description

Move Select Entire Object to edit all the vertices of the surface, 
Vertex Only to edit only the selected vertex, U Vertices 
to edit all of the vertices in a row in the U direction, and V 
Vertices to edit all of the vertices in a row in the V 
direction

Edit U/V Scrolls through the vertices of the selected NURBS surface 
in either the U parametric direction or V parametric 
direction

X, Y, Z / I, J, K Depending on the selection in the Move pulldown list, 
displays the position of the current surface or vertex; edit 
the values to change the surface/vertex position 

U Degree Degree in the U parametric direction; increasing this value 
adds vertices that can then be manipulated

V Degree Degree in the V parametric direction; increasing this value 
adds vertices that can then be manipulated

Weight NURBS curves and surfaces are represented 
mathematically by weighted control points. The weight 
value can be anywhere between .01 and 100. A weight 
above 1 pulls the curve or surface towards the control 
point; a weight below 1 has the reverse effect.

Reverse Normal Flips the surface normal direction

Remove Holes Removes the holes in a trimmed NURBS surface

NURBS Surface parameters 
(display only)

Displays the NURBS surface parameters

Show Control Points Select the checkbox to display the surface’s control points
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Composing Surfaces

The Compose command (formerly called the Compose Curve command) 
can now combine several NURBS surfaces into one. In addition, as it did 
previously, this command can compose 2D lines, arcs, open polygons, 
NURBS curves, NURBS arcs, and open 3D polygons.
Adjacent NURBS surfaces, which may have been split by the Split tool (see 
“Splitting NURBS Surfaces” on page 1-26), can be composed into a single 
NURBS surface with this command.
To compose adjacent NURBS surfaces:
1. Select the NURBS surfaces to be composed.

2. Select Tool > Compose. The objects are combined to create a single 
NURBS surface.

Decomposing Surfaces

The Decompose command (formerly called the Decompose Curve 
command) can now decompose NURBS surfaces. In addition, as it did 
previously, this command can decompose 2D polygons, 2D polylines, 3D 
NURBS curves created with the Compose command, and open 3D 
polygons.
Occasionally, surface creation methods like the Create Surface from 
Curves command can create a surface with internal discontinuities. Many of 
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the 3D Power Pack tools and commands are not designed to work with these 
types of surfaces. The Decompose command can separate the surface into 
NURBS surfaces without discontinuities.
To decompose a NURBS surface:
1. Select the NURBS surface to be decomposed.

2. Select Tool > Decompose.

The NURBS surface is separated into individual surfaces.

Splitting NURBS Surfaces

The Split tool now includes NURBS surfaces among the objects that it can 
split.
Note: Surfaces generated by successive splitting can be joined together with 

the Compose command (see “Composing Surfaces” on page 1-25).

This command may not be able to manipulate certain types of surface 
geometry (see “Surface Geometry Requirements” on page 1-7).

Select the mode from the Mode bar.

One section moved for clarity

Split Tool
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Point Split Mode

To split a NURBS surface in point split mode:
1. Click the Split tool from the Editing palette.

2. Click the Point Split mode from the Mode bar.

3. In Wireframe view, click on the NURBS surface to split.

Note: See “Selecting the Edges and Faces of a Solid” on page 1-3 for 
information on selecting surfaces.

The surface is split by iso-parametric curves passing through the click 
point along u and v parametric directions.

Note: If the point is on an existing iso-parametric curve, the surface is split 
in both directions (u and v).

Line SplitPoint Split

Click to select the NURBS surface The selected surface is 
split at that point

The smaller surface has 
been moved for clarity
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Line Split Mode

To split a NURBS surface in line split mode:
1. Click the Split tool from the Editing palette.

2. Click the Line Split mode from the Mode bar.

3. Draw a line to split the NURBS surface.

The surface is split by the line.

Note: Solids can also be split in Line Split mode. Two Section Solid objects 
will result.

Clicking once on the 
iso-parametric curve (shown in 
light gray) with the Split tool 
creates four split surfaces (in 
black)

One split surface has been 
moved for clarity

One solid section has been moved for clarity
1-28 VectorWorks 3D Power Pack User’s Guide



NURBS Surface-Curve Interaction 1
NURBS Surface-Curve Interaction

Trimming NURBS Surfaces with a Projection

The Project and Trim tool projects a 2D object or NURBS curve onto a 
NURBS surface, and then trims the NURBS surface according to the region 
selected. This allows nonlinear trimming of surfaces to create different shapes 
or cutting a hole in an object.

To trim a NURBS surface with a projection:
1. In the desired view, draw a 2D object or NURBS curve on top of a 

NURBS surface.

Note: If the object to be projected is an open NURBS curve, both end points 
must be outside the NURBS surface.

2. Click the Project and Trim tool from the 3D Tools palette.

3. Click on the trimming object, and then click on the NURBS surface. The 
cursor changes into the pointing hand cursor. Click on the side of the 
intersection to be trimmed away.

Project and Trim 
Tool

Select the project and 
trimming object

Select the NURBS surface Select the region to be 
trimmed
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The trimming object is projected onto the NURBS surface, and the 
region selected to be trimmed away is removed from the NURBS surface 
at the point of intersection.

Solids Operations

Blending Edges

The Blend Edge tool removes the sharp corners of a solid by blending the 
edges. The edge can be blended by either a fillet (blending by a surface with a 
circular cross section) or a chamfer (blending by a surface with a linear cross 
section).
Edges are usually blended during the detailed design phase of a project. This 
may reduce the heat and/or stress concentration in manufacturing and can 
provide a more realistic or aesthetic appearance to a model.
To blend the edges of a solid:
1. Click the Blend Edge tool from the 3D Tools palette.

2. Specify the blend edge preferences by clicking the Preferences button on 
the Mode bar. The Blend Edge Preferences dialog box opens.

Blend Edge Tool
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3. Click OK to close the Blend Edge Preferences dialog box.

4. For tangent entity selections, select the tangentially-connected edges and 
faces to be blended. For face selections, select the faces to be blended. 
Hold the Shift key down to select several faces and edges.

Note: See “Selecting the Edges and Faces of a Solid” on page 1-3 for 
information on selecting edges and faces.

5. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to perform the edge blend.

Parameter Description

Type Select Fillet (smooth transition between surfaces) or 
Chamfer (planar surface between the faces) as the blend 
type

Radius/Setback When fillet is selected, indicate the Radius of the fillet 
surface; for Chamfer blends, specify the distance by which 
the faces are set back (Setback)

Select Tangent Entities Choose this option to select tangentially-connected edges and 
faces for blending

Select Faces Choose this option to select faces for blending

Select the type of
edge blend

Choose the method
of selecting the

faces and/or edges
for blending

Specify the 
degree to which 
the blending will 
occur
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The blended edge radius or setback value can be edited through the Object 
Info palette.

Note: Once the blend is created, the edge set used to create the blend cannot 
be changed. The blend can be ungrouped, and a new blend with 
different edges can be created.

If a blend has been created over another blend, the first blend cannot 
be edited in the Object Info palette unless the blends are first 
ungrouped (see “Editing a Fillet/Chamfer or Shell Object” on page 
1-6).

A blend edge operation may fail due to:
• complex surface geometry adjacent to an edge or corner involved in the 

blend;
• a radius value that is too large;

Wireframe – before blending Rendered – before blending

Wireframe – after blending Rendered – after blending

Edit the radius for fillet 
blends or the setback 
distance for chamfer 
blends
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• an attempt to blend one edge in a sequence of tangential edges (select all 
the edges for a better chance of success); or

• an attempt to blend without selecting all the edges in a vertex.

Creating a Shell from a Solid Object

The Shell Solid tool creates a hollow shell from a solid object. The shell can 
be created outside the solid or inside. Most injection-molded plastic parts 
have a shell.
To create a shell solid from a solid object:
1. Click Shell Solid from the 3D Tools palette.

2. Click on the face of the solid object to create the shell into.

The Shell Solid Preferences dialog box opens.

Shell Solid Tool
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3. Specify the desired shell settings.

Note: Click the Shell Solid Preferences button on the Mode bar to edit 
settings.

4. Click OK.

The selected face of the object is highlighted in red.

5. Press Enter (Win) or Return (Mac), or the check mark button on the 
Mode bar, to create the shell.

Note: If the wrong face is highlighted, select the correct face before pressing 
Enter.

Parameter Description

Shell Thickness Enter the thickness of the shell wall. The distance is 
calculated from the edge of the selected face. A 
negative number creates an interior shell; a positive 
number creates an exterior shell. The edges of an 
exterior shell are automatically blended.

Select Tangent Faces Selects the tangentially-connected chain of faces
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Creating a Tapered Extrude

A tapered extrude can now be created from 3D polygons and NURBS curves, 
circles, and arcs, in addition to the 2D objects previously supported. This 
command easily creates wavy extrusions by entering a taper value of zero.
To create a tapered extrude:
1. Select the object to turn into a tapered extrude.

2. Select Model > Tapered Extrude.

The Set Tapered Angle and Extrude Height dialog box opens.

3. Enter the Height (Z) of the extrude and the Taper Angle.

4. Click OK to create the tapered extrude.

NURBS Curve

Set a Taper Angle of 0 
to create an extrusion 
with no taper
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Stitching and Trimming Surfaces

The Stitch and Trim Surfaces command creates a group of trimmed 
NURBS surfaces from several intersecting surfaces (including NURBS 
surfaces or solids such as extrudes or sweeps). 
Note: This command may not be able to manipulate certain types of surface 

geometry. See “Surface Geometry Requirements” on page 1-7.

To stitch and trim intersecting surfaces:
1. Select the intersecting surfaces. 

Note: The surfaces must enclose a volume.

2. Select Model > Stitch and Trim Surfaces.

The surfaces enclosing the volume are stitched together and then 
trimmed, resulting in a group of trimmed NURBS surfaces.
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Sectioning Solids

The Section Solids command discards a portion of solids or NURBS 
surfaces, allowing the creation of planar or stepped sections through a solid or 
surface. The sectioned surface can be “marked” by the sectioning surface 
color.
To section a solid:
1. Select the solid or surface to be sectioned, along with the sectioning 

surface.

2. Select Model > Section Solids. In the Select Object dialog box, 
specify which object is to be used as the sectioning surface. By default, 
the most recently created object is highlighted, but a different object can 
be selected by clicking the arrows.

Note: The sectioning surface must be larger than the solid being sectioned.

3. When the desired sectioning surface is selected, click OK.

The solid is sectioned by the sectioning surface. The remaining object 
becomes a solid section.

The sectioning surface is 
highlighted (select it with 
the arrows in the dialog 
box) 
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Exporting in 3D Power Pack

Exporting in IGES Format (3D only)

A new export capability has been added to VectorWorks with the 3D Power 
Pack. The Export IGES (3D only) command exports 3D curves, surfaces 
and solids from VectorWorks into IGES format (version 5.3). Closed solids 
are exported as solids, while open solids are exported as a collection of 
surfaces.
Objects that are exported to an *.igs file from VectorWorks include: 

• Groups 
• Symbols 
• Parametric objects 
• NURBS curves and surfaces 
• Solids (sphere/cone/hemisphere) 
• Extrudes and multiple extrudes 
• Sweeps 
• CSG solids (add/subtract/intersect/section) 

Parameter Description

Width/Depth/Height 
(Display only)

Displays the parameters of the solid section surface

Reverse Section Side Switches the remaining side of the solid being sectioned

Use Section Color Applies the color of the sectioning surface to the sectioned 
surface
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• Fillet 
• Chamfer 
• Shell 
• 3D polygons 

To export a file to the IGES format:
1. Select File > Export > Export IGES (3D only).

The Export IGES Options dialog box opens.

2. To export solids as trimmed surfaces, select the checkbox, and then click 
OK.

3. Specify the file name and destination. Click Save.

If the exported item is a: It is exported as an:

NURBS curve IGES Entity Type 126

NURBS surface IGES Entity Type 128

Trimmed NURBS surface IGES Entity Type 144

Closed solid IGES Entity Type 186
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2Extracting Curves From Solids
In this Tutorial:

• Setting Up the 
Modeling Units

• Creating a Block

• Blending Edges

• Hollowing Out the 
Block

• Extracting Curves

• Creating the 
Groove
This tutorial explains the basics of extracting curves from a 
solid.

Setting Up the Modeling Units

This tutorial works in inches.
To set up the units for modeling distances in inches: 
1. Select Page > Units. 

2. In the Units dialog box, select Inches from the Unit 
Name pulldown menu.

All distances entered for designs will now be in 
inches.

Creating a Block

1. Double-click the Rectangle tool from the 2D Tools 
palette.

The rectangle object properties dialog box opens. 
Enter the following settings:

Rectangle 
Tool
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2. Click OK to place.

A rectangle is placed in the center of the drawing area.

3. Extrude the rectangle. With the square selected, click Model > 
Extrude. In the Create Extrude dialog box, enter 3” for the Extrusion 
value. Click OK to create an extrude object.

Blending Edges

1. Select View > Standard Views > Right Isometric.

2. Click the Blend Edge tool from the 3D Tools palette.

3. Click on one of the vertical edges of the block.

The Blend Edge Preferences dialog box opens. 

4. Enter 3/4” for the Radius, and then click OK.

5. Holding the Shift key down, select all of the vertical edges of the block.
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Each edge will change to red as it is selected.

6. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar.

Hollowing Out the Block

1. Click the Shell Solid tool from the 3D Tools palette.

2. Click on the top face of the block.

The Shell Solid Preferences dialog box opens.

3. Enter 1/4” as the Shell Thickness, and then click OK.

Shell Solid 
Tool
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The top face of the block is highlighted in red.

4. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to create the shell.

Extracting Curves

1. Click the Extract Curve tool from the 3D Tools palette.

2. Holding the Shift key down, select all of the top inner edges of the block.

Extract Curve 
Tool
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3. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar.

4. Select Organize > Ungroup.

5. Select Tool > Compose.

Creating the Groove

1. Click the Ellipse tool from the 2D Tools palette, and then select the 
Circle by Radius mode from the Mode bar.

2. In an unused area of the drawing, create a circle with a 1/8” radius.

3. Holding the Shift key, select the circle and the red NURBS curve created 
earlier.

4. Select Model > Extrude Along Path.

The Select Path Object dialog box opens.

5. Use the arrow buttons to select the NURBS curve as the path object, and 
then click OK.

6. Holding down the Shift key, select the block and the extruded-along-path 
object.

Ellipse 
Tool
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7. Select Model > Subtract Solids.

The Select Object dialog box opens.

8. Use the arrow buttons to select the block, and then click OK to create the 
groove.

9. To render the model, use the Light tool from the 3D Tools palette to 
insert a light source, and then select View > Rendering > OpenGL.Light Tool
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3Creating and Modifying NURBS 
Surfaces
In this Tutorial:

• Setting Up the 
Modeling Units

• Creating a Block

• Creating NURBS 
Surfaces

• Reshaping the 
NURBS Surface

• Creating the Solid

• Smoothing the 
Edges
In this tutorial, the body of a telephone handset is created to 
learn the basics of creating and modifying NURBS 
surfaces.

Setting Up the Modeling Units

This tutorial works in inches.
To set up the units for modeling distances in inches: 
1. Select Page > Units. 

2. In the Units dialog box, select Inches from the Unit 
Name pulldown menu.

All distances entered for designs will now be in 
inches. 

Creating a Block

1. Click the Rectangle tool from the 2D Tools palette 
and draw a 6”x1.5” rectangle.

2. Extrude the rectangle. With the rectangle selected, 
click Model > Extrude. In the Create Extrude dialog 
box, enter 1.5” for the Extrusion value. Click OK to 
create an extrude object. 

Rectangle 
Tool
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Creating NURBS Surfaces

1. Convert the extrude object to NURBS surfaces using the Model > 
Convert to NURBS command, which creates a group of NURBS 
surfaces. 

2. Select Organize > Ungroup to get six individual surfaces for the six 
faces of the extrusion. Deselect all the surfaces. 

3. Change the view to front view by selecting View > Standard Views > 
Front. Draw a marquee box around the top surface to select it. Change 
the view to right isometric by selecting View > Standard Views > 
Right Isometric. Make sure that the top surface is still selected. 

4. Open the Object Info palette. At this point, the NURBS surface 
properties are as follows:

Reshaping the NURBS Surface

1. In the Object Info palette, change U Degree to 2 and V Degree to 2. 
The number of vertices of the selected NURBS surface should now be 9. 

2. In Edit, click on the arrow(s) until the vertex at the center of the top 
surface is selected.
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3. From the Move pulldown list, select Vertex Only. 

4. The Z value for the selected vertex is 1.5”. Change the Z value from 1.5” 
to 3”. The surface becomes dome shaped.

5. Change to front view by selecting View > Standard Views > Front. 
Deselect the top surface and draw a marquee box around the bottom 
surface to select it. 

6. Reshape the bottom surface as described in steps 1 – 4. Change the Z 
value for the vertex at the middle of the bottom surface from 0 to 1.5”.

Creating the Solid

Select all the surfaces and add them together by selecting Model > Add 
Solids. 
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Smoothing the Edges

1. Click the Blend Edge tool from the 3D Tools palette. Open the Blend 
Edge Preferences dialog box by clicking on the Preferences button in the 
Mode bar. 

2. Enter 0.5” in the Radius field, and then click OK. 

3. Press the Shift key and select the four vertical edges. Perform the blend 
by pressing Enter (Win) or Return (Mac) or the check mark button on the 
Mode bar.

4. Open the Blend Edge Preferences dialog box by clicking the button in 
the Mode bar. Select the Select Tangent Entities checkbox. Enter 
0.4” in the Radius field, and then click OK. 

Blend Edge Tool
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5. Press the Shift key and select the tangential sequence of edges at the top 
and at the bottom. Press Enter (Win) or Return (Mac) or the check mark 
button on the Mode bar to blend the selected edges.

6. To render the model, use the Light tool from the 3D Tools palette to 
insert a light source, and then select View > Rendering > OpenGL.

Light Tool
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4Creating Surface Models
In this Tutorial:

• Setting Up the 
Modeling Units

• Creating a Flat 
NURBS Surface

• Reshaping the 
NURBS Surface

• Creating a 
Trimmed Surface

• Creating the Hat 
Shape
In this tutorial, construct a hat-shaped solid to learn how to 
create and modify NURBS surfaces and perform surface 
trimming.

Setting Up the Modeling Units

This tutorial works in inches.
To set up the units for modeling distances in inches: 
1. Select Page > Units. 

2. In the Units dialog box, select Inches from the Unit 
Name pulldown menu.

All distances entered for designs will now be in 
inches.

Creating a Flat NURBS Surface

1. Click the Rectangle tool from the 2D Tools palette 
and draw a 6” x 6” square in the center of the drawing 
area. 

Rectangle
Tool
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2. Extrude the square. With the square selected, click Model > Extrude. 
In the Create Extrude dialog box, enter 0 (zero) for the Extrusion value. 
Click OK to create an extrude object with zero height.

3. Select Model > Convert to NURBS. 

The extrude object is converted to NURBS surfaces. 

Reshaping the NURBS Surface

1. In the Object Info palette, change both the U Degree and V Degree 
values to 2. 

The number of Vertices for the selected NURBS surface is now 9. 

2. In the Move field, select Vertex Only from the pulldown menu. 

3. In the Edit field, press the arrow key until one of the vertices in the 
center “column” is highlighted. Change the Z value to 2. Repeat this 
process to highlight and change the Z value of each of the remaining two 
vertices in the center “column.” This creates a curvy surface. 

4. Select View > Standard Views > Right Isometric.

The surface displays as follows.

Center 
Vertices
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Creating a Trimmed Surface

1. Select View > Standard Views > Top to change to drawing view. 

2. Click the Ellipse tool from the 2D Tools palette, and then select the 
Circle by Radius mode from the Mode bar.

3. Draw a circle at the center of the NURBS surface with a 2.75” radius. 

4. Click the Project and Trim tool from the 3D Tools palette. Select the 
circle, select the surface, and then indicate the region outside the circle to 
be trimmed away. 

5. Select View > Standard Views > Right Isometric.

The surface displays as follows.

Creating the Hat Shape

1. Select View > Standard Views > Top. 

2. Click the Ellipse tool from the 2D Tools palette, and then select the 
Circle by Radius mode from the Mode bar.

3. Draw a circle at the center of the NURBS surface with a 1.5” radius. 

Ellipse Tool

Project and 
Trim Tool

Select circle Select surface Select region

Ellipse Tool
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4. Select the circle, and then select Model > Tapered Extrude. 

The Set Tapered Angle and Extrude Height dialog box opens.

5. Enter a 2” Height(Z), leave the Taper Angle value as is, and then click 
OK.

A tapered extrude object is created. 

6. Select Edit > Select All. Select Model > Add Solids to add the 
tapered extrusion to the NURBS surface.

7. To render the model, use the Light tool from the 3D Tools palette to 
insert a light source, and then select View > Rendering > OpenGL.

8. Click the Flyover tool from the 3D Tools palette and click-drag until the 
hat displays as follows.

9. With the hat selected, click Model > Convert to NURBS to convert all 
the surfaces of the solid to NURBS surfaces. Select Organize > 
Ungroup to display all individual surfaces.

10. Select View > Rendering > Wireframe to switch to wireframe view.

Light Tool

Flyover Tool
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Creating the Hat Shape 4
11. Click on the drawing area to deselect the objects. Delete the two surfaces 
underneath the big round surface.

12. Delete the surface at the middle of the big round surface, thus creating a 
hole in the big round surface.

Note: You may have to draw a marquee box around the surface in order to 
select it. 

At this point there are three surfaces.

13. From the Attributes palette, assign colors to the surfaces, as indicated.

14. Select Edit > Select All. Select Model > Add Solids to add the 
surfaces together. 

15. Click the Blend Edge tool from the 3D Tools palette. 

16. Select the top edge of the hat.

pink

blue

green

Blend Edge 
Tool
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Creating Surface Models
The Blend Edge Preferences dialog box opens.

17. Enter 0.2” in the Radius/Setback field, and then click OK.

18. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to blend the edges.
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5Creating and Modifying Free-form 
Shapes
In this Tutorial:

• Setting Up the 
Modeling Units

• Creating the 
Cross Sections

• Setting Up the 
Cross Section

• Creating the Vase 
Shape

• Hollowing Out the 
Vase

• Blending the 
Edges
In this tutorial, you will construct a vase in order to learn 
the basics of creating and modifying free-form shapes.

Setting Up the Modeling Units

This tutorial works in inches.
To set up the units for modeling distances in inches: 
1. Select Page > Units. 

2. In the Units dialog box, select Inches from the Unit 
Name pulldown menu.

All distances entered for designs will now be in 
inches.

Creating the Cross Sections

To create the cross sections:
1. From the View bar, click Fit to Window.

2. Click the Rectangle tool from the 2D Tools palette.Rectangle 
Tool
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Creating and Modifying Free-form Shapes
3. Click on the lower left side of the drawing area, and then press Tab to 
highlight the +/-X field. Enter 6”, and then press Enter (Win) or Return 
(Mac). 

4. Press Tab until the +/-Y field is highlighted. Enter 5”, and then press 
Enter (Win) or Return (Mac). Click on the drawing area to set the 
rectangle.

5. With the rectangle still highlighted, select Edit > Copy.

6. Select Edit > Paste.

A copy of the rectangle is placed on the drawing.

7. Select the Rectangle tool.

8. Click on the drawing, and then press Tab to highlight the +/-X field. 
Enter 3”, and then press Enter (Win) or Return (Mac). Press Tab until the 
+/-Y field is highlighted. Enter 3”, and the press Enter (Win) or Return 
(Mac). Click on the drawing area to set the square.

A square is created.

Setting Up the Cross Section

To set up the cross section:
1. Click the 2D Selection tool from the 2D Tools palette.

2. Select Edit > Select All.

3. Select Model > Convert to NURBS.
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Setting Up the Cross Section 5
4. Select Organize > Ungroup.

5. Deselect the rectangles by clicking on a unused area of the drawing.

6. Select Palettes > Object Info.

The Object Info palette opens.

7. Select one of the two larger rectangles.

8. In the Object Info palette, enter 3” for the Z value.

9. Select the other large rectangle, and then enter -3” for the Z value in the 
Object Info palette.

10. Click on the drawing area, and then select Edit > Select All.

11. Select Tool > Align > Align/Distribute.

The Align/Distribute Objects dialog box opens.

12. Select Align and Center for both the vertical and horizontal.
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Creating and Modifying Free-form Shapes
13. Click OK.

14. Select View > Standard Views > Right Isometric.

Creating the Vase Shape

To create the body of the vase:
1. Click the Loft Surface tool from the 3D Tools palette.

2. Click on the left corner of the bottom square, and then click on the left 
corner of the middle rectangle.

The two corners are connected by a red line representing the beginning 
of proposed curve. 

3. Click on the left corner of the top square. 

The loft curve is completed.

Loft Surface 
Tool
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Creating the Vase Shape 5
Note: If the wrong connections are selected, double-click on the last point to 
cancel the operation, and then start again.

4. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to accept the proposed curve.

The Loft Creation dialog box opens.

5. Select Create Solid and then click Preview.

A preview of the final shape is displayed.
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Creating and Modifying Free-form Shapes
6. Click OK to accept the settings.

7. To view the model rendered, use the Light tool from the 3D Tools 
palette to insert a light source, and then select View > Rendering > 
OpenGL.

Hollowing Out the Vase

To hollow out the vase:
1. Select View > Rendering > Wireframe.

2. Click the Shell Solid tool from the 3D Tools palette.

3. Click on the top face of the vase.

The Shell Solid Preferences dialog box opens.

Light Tool

Shell Solid 
Tool
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Hollowing Out the Vase 5
4. Enter -3/4” as the Shell Thickness, and then click OK.

The top face of the vase is highlighted in red.

5. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to create the shell.

Note: If the wrong face is highlighted, select the correct one before pressing 
Enter.
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Creating and Modifying Free-form Shapes
Blending the Edges

All the edges of the vase can be blended to give them a smoother and rounder 
appearance.
To blend edges:
1. Select View > Rendering > Wireframe.

2. Click the Blend Edge tool from the 3D Tools palette.

3. Click on one of the vertical edges of the vase.

The Blend Edge Preferences dialog box opens. 

4. Enter 1/4” for the Radius, and then click OK.

5. Holding the Shift key down, select all of the vertical edges of the vase.

Each edge will change to red as it is selected.

Rotate the drawing using the Flyover tool from the 3D Tools palette to 
make selection easier. To obtain the flyover tool in Boomerang mode, 

Blend Edge 
Tool
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Blending the Edges 5
press spacebar + B. Release the spacebar + B to return to the Blend 
Edge tool.

6. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to accept the selections and blend the edges.

7. Click the Blend Edge Preferences button on the Mode bar.

The Blend Edge Preferences dialog box opens.

8. Enter 1/5” for the Radius and select the Select Tangent Entities 
checkbox.

9. Click OK.

10. Holding the Shift key, select the tangentially-connected chain of edges.

11. Press Enter (Win) or Return (Mac) or the check mark button on the Mode 
bar to blend the edges.
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6Sectioning Solids
In this Tutorial:

• Setting Up the 
Modeling Units

• Creating a Block

• Creating the 
Sectioning 
Surfaces

• Sectioning the 
Solid
This tutorial covers the basics of sectioning solids by 
creating a mallet head.

Setting Up the Modeling Units

This tutorial works in inches.
To set up the units for modeling distances in inches: 
1. Select Page > Units. 

2. In the Units dialog box, select Inches from the Unit 
Name pulldown menu.

All distances entered for designs will now be in 
inches.

Creating a Block

1. Click the Rectangle tool from the 2D Tools palette 
and draw a 6”x 6” square.

2. Extrude the square. With the square selected, click 
Model > Extrude. In the Create Extrude dialog box, 
enter 6” for the Extrusion value. Click OK to create 
an extrude object.

Rectangle 
Tool
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Sectioning Solids
Creating the Sectioning Surfaces

Now create the surfaces that will serve as the sectioning surfaces for the 
mallet head.

Creating and Extruding the Polygon

1. At the top left corner of the extrude, use the 2D Polygon tool (located 
on the 2D Tools palette) to draw a polygon with the dimensions shown 
below.

2. Select the polygon, and then click Edit > Duplicate Array command. 
The Duplicate dialog box opens. Make the following settings:

3. Click OK to duplicate the original polygon seven times, offset by 1” in 
the X direction. Select all the polygons by drawing a marquee around 
them with the 2D Selection tool (located on the 2D Tools palette).

2D Polygon Tool

2D Selection Tool
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Creating the Sectioning Surfaces 6
4. Compose the polygons into a single polygon by selecting Tool > 
Compose.

5. Extrude the polygon. With the composed polygon selected, click
Model > Extrude. In the Create Extrude dialog box, enter 8” for the 
Extrusion value. Click OK to create an extrude object.

6. Move the extrude object down by selecting Tool > Move > Move 3D 
and entering -1” for Z Offset.

Creating the Sectioning Surfaces

1. Convert the extrusion to NURBS surfaces by selecting Model > 
Convert to NURBS. Ungroup the NURBS surfaces by selecting 
Organize > Ungroup.

2. Add the surfaces by selecting Model > Add Solids. The solid that is 
created will be used as the sectioning surface. Select View > Standard 
Views > Right Isometric to view the objects in 3D.
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Sectioning Solids
3. Copy the selected sectioning surface by clicking Edit > Copy, and then 
paste the copy with the Edit > Paste in Place command. Rotate the 
selected copy by selecting Tool > Rotate > Rotate 3D. Enter the 
following parameters:

The copy of the sectioning surface is rotated 90o from the original. There 
are now two sectioning surfaces.

4. The two sectioning surfaces will be mirrored to create four sectioning 
surfaces, with each pair on opposite sides of the mallet head. Switch to 
Top view by selecting View > Standard Views > Top.

5. In the center of the rectangle, draw a guide line (using the Line tool from 
the 2D Tools palette) to serve as a guide for mirroring.Line Tool

Guide line
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Sectioning the Solid 6
6. With both sectioning surfaces selected, click the 3D Mirror tool from the 
3D Tools palette. In Duplicate and Mirror mode, draw the axis line 
over the guide line. Delete the guide line.

Switch the view by selecting View > Standard Views > Right Isometric. 
There are now four sectioning surfaces, with two on each side of the block.

Sectioning the Solid

1. Select the block and one of the sectioning surfaces. Select Model > 
Section Solids. Ensure that the selection surface is highlighted (if it is 
not, use the arrow keys to select it).

2. Click OK to section the solid with the sectioning surface. If sectioning 
produced the incorrect part of the block, click Reverse Section Side 
from the Object Info palette.

3D Mirror Tool
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Sectioning Solids
3. Repeat the sectioning procedure with the remaining three sectioning 
surfaces. The mallet head is complete.

If necessary, click to 
keep the relevant 
portion of the block
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